In-Portal Issue Tracker - In-Portal CMS
Viewing Issue Advanced Details
987 [In-Portal CMS] Other bug report always 2011-02-02 20:09 2011-03-30 09:53
Dmitry  
alex  
normal  
closed 5.1.2-B1  
fixed  
 
none 5.1.2-B2  
https://groups.google.com/d/topic/in-portal-bugs/0V4IGZ-27NM/discussion
Corrected location of favicon.ico file
0
0000987: Incorrect location of "favicon.ico" file
In-Portal has it's own favicon.ico file, located in "core/admin_templates/img" folder. This icon is used when In-Portal based website is added to favorites and also on the left on website address in web browser.

Internet Explorer doesn't like that much and it requires that "favicon.ico" file will be placed in root installation folder.

I can see that, because I still got requests to "favicon.ico" file in root folder of installation no matter if I have specified other path in each page HTML.

In result we should have 1 version of "favicon.ico" file for both admin console and front-end and not 2 files with identical content.
Proper way:

1. place "favicon.ico" file in the ROOT folder of installation
2. place this HTML into <head> section of HTML page:

<link rel="icon" href="<inp2:m_BaseURL/>favicon.ico" type="image/x-icon" />
<link rel="shortcut icon" href="<inp2:m_BaseURL/>favicon.ico" type="image/x-icon" />
parent of 0000997closed  (1.1.2)alex Advanced Incorrect location of "favicon.ico" file 
parent of 0000998closed  (5.1.2)alex Default Incorrect location of "favicon.ico" file 
parent of 0000999closed  (1.1.2)alex Simple Incorrect location of "favicon.ico" file 
? favicon.ico (1,054) 2011-02-09 12:52
http://tracker.in-portal.org/file_download.php?file_id=939&type=bug
patch Incorrect-location-of-favicon-.ico-file.patch (1,259) 2011-02-09 13:31
http://tracker.in-portal.org/file_download.php?file_id=940&type=bug
Issue History
2011-03-30 09:53 Dmitry Note Added: 0003336
2011-03-30 09:53 Dmitry Status resolved => closed
2011-02-15 08:39 alex Note Added: 0003241
2011-02-15 08:39 alex Status reviewed and tested => resolved
2011-02-15 08:39 alex Fixed in Version => 5.1.2-B2
2011-02-15 08:39 alex Resolution open => fixed
2011-02-15 08:39 alex Assigned To !COMMUNITY => alex
2011-02-15 08:39 alex Changeset attached 5.1.x r14189
2011-02-15 08:32 alex Changeset attached 5.1.x r14188
2011-02-15 08:31 alex Note Added: 0003240
2011-02-15 08:31 alex Assigned To alex => !COMMUNITY
2011-02-15 08:31 alex Status needs testing => reviewed and tested
2011-02-09 13:39 Dmitry Relationship added parent of 0000999
2011-02-09 13:36 Dmitry Relationship added parent of 0000998
2011-02-09 13:33 Dmitry Note Added: 0003226
2011-02-09 13:33 Dmitry Assigned To => alex
2011-02-09 13:33 Dmitry Developer => Dmitry
2011-02-09 13:33 Dmitry Status active => needs testing
2011-02-09 13:31 Dmitry File Added: Incorrect-location-of-favicon-.ico-file.patch
2011-02-09 13:25 Dmitry Relationship added parent of 0000997
2011-02-09 12:52 Dmitry File Added: favicon.ico
2011-02-02 20:09 Dmitry New Issue
2011-02-02 20:09 Dmitry Reference => https://groups.google.com/d/topic/in-portal-bugs/0V4IGZ-27NM/discussion
2011-02-02 20:09 Dmitry Change Log Message => Corrected location of favicon.ico file

Notes
(0003226)
Dmitry   
2011-02-09 13:33   
Please test.

Need to DELETE favicon.ico from "core/admin_templates/img" folder.

Move to the ROOT of In-Portal?

(0003240)
alex   
2011-02-15 08:31   
ok
(0003241)
alex   
2011-02-15 08:39   
Fix committed to 5.1.x branch. Commit Message:

Fixes 0000987: Incorrect location of "favicon.ico" file
Commit on behalf of Dmitry
(0003336)
Dmitry   
2011-03-30 09:53   
Closing, since 5.1.2 release has been released.