In-Portal Issue Tracker - In-Portal CMS
Viewing Issue Advanced Details
843 [In-Portal CMS] Admin Interfaces bug report always 2010-08-31 09:39 2011-03-30 09:53
erik  
alex  
normal  
closed 5.1.0  
fixed  
 
none 5.1.2-B1  
http://groups.google.com/group/in-portal-bugs/browse_thread/thread/f0c58909d3dec17e
0
0000843: User login isn't escaped in user selector
Because of typing error in parameter name ("js_ecape" instead of "js_escape") user login isn't escaped resulting to js error in some cases, when attempt is made to select user.
patch user_selector_login_not_escaped.patch (584) 2010-08-31 09:39
http://tracker.in-portal.org/file_download.php?file_id=740&type=bug
Issue History
2011-03-30 09:53 Dmitry Note Added: 0003343
2011-03-30 09:53 Dmitry Status resolved => closed
2011-01-09 13:39 alex Note Added: 0003189
2011-01-09 13:39 alex Status reviewed and tested => resolved
2011-01-09 13:39 alex Fixed in Version => 5.1.2-B1
2011-01-09 13:39 alex Resolution open => fixed
2011-01-09 13:39 alex Changeset attached 5.1.x r14145
2010-09-28 14:06 Dmitry Fixed in Version 5.1.2 =>
2010-09-28 14:06 Dmitry Target Version Icebox => 5.1.2
2010-09-28 12:14 Dmitry Fixed in Version => 5.1.2
2010-09-07 09:36 alex Note Added: 0002787
2010-09-07 07:59 Dmitry Note Added: 0002785
2010-09-07 07:59 Dmitry Assigned To !COMMUNITY => alex
2010-09-07 07:59 Dmitry Status needs testing => reviewed and tested
2010-08-31 09:40 alex Assigned To => !COMMUNITY
2010-08-31 09:40 alex Developer => alex
2010-08-31 09:40 alex Status active => needs testing
2010-08-31 09:39 alex Reference => http://groups.google.com/group/in-portal-bugs/browse_thread/thread/f0c58909d3dec17e
2010-08-31 09:39 alex Reporter alex => erik
2010-08-31 09:39 alex File Added: user_selector_login_not_escaped.patch
2010-08-31 09:39 alex New Issue

Notes
(0002785)
Dmitry   
2010-09-07 07:59   
Reviewed and tested. I propose to move this to 5.1.1 to get it out of the way.
(0002787)
alex   
2010-09-07 09:36   
Not a big issue, since nobody ever tried to enter symbols, that needs to be escaped in username: ' and ".
(0003189)
alex   
2011-01-09 13:39   
Fix committed to 5.1.x branch. Commit Message:

Fixes 0000843: User login isn't escaped in user selector
(0003343)
Dmitry   
2011-03-30 09:53   
Closing, since 5.1.2 release has been released.